qbXML components have not been installed error
Question asked by Damian Webber - 12/14/2022 at 11:04 AM

I started to get this error a couple of months ago and have been unable to get ZedAxis to work ever since.

I've trawled the web for every mention of this and possible fixes and nothing has worked.

Repairing the QB installation
Using the QB tool to go over everything installed.
Uninstalling QB and then reinstalling.
Uninstall and Reinstall of ZedAxis.
Making sure QB is updated to the latest version.
Renaming the TLG files and restarting
Running QB & Zed and every combination in administrator mode.

To keep me going I tried it on my laptop and surprisingly it works fine on that, so that has kept me going but it's not ideal.

The only difference I can see between the 2 installations is that the laptop that works has R4_83 and the desktop has R4_85. Just now the laptop has said that it has a critical update to install but trying to avoid restarting the laptop in case it's the R4_85 that is the issue

Does anyone have any other ideas of things to try ?

1 Reply

Reply to Thread
Steve Replied
Employee Post Marked As Answer
Hi Damian,

Can try running the Reboot.bat file that is in the QuickBooks program files folder that will fix any registration errors with the interface components.

Steve Batten

Reply to Thread